Unmet Dependencies when installing SQL Server on Ubuntu

Some people while installing SQL Server on Ubuntu get an error that some packages could not be installed or some packages have unmet dependencies.

Here how it looks like:

Reading package lists... Done
Building dependency tree 
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mssql-tools : Depends: libstdc++6 (>= 5.2) but 4.9.2-10ubuntu13 is to be installed
E: Unable to correct problems, you have held broken packages.

If you found yourself in such a situation then probably your Ubuntu is a bit old. SQL Server on Linux supports at least Ubuntu 16.04 so the best solution here to upgrade your OS.

If you are unsure about your Ubuntu’s version you can run the following command in a terminal:

lsb_release -a

or check it in System Settings -> Details if you prefer GUI.

Leave a Reply

Your email address will not be published.